re = /news\/(?P<issue_number>[^\\.\/]+)\.(?P<fragment_type>removal|feature|bugfix|vendor|doc|process|trivial)(\.\d+)?(\.[^\\.\/]+)*\.rst$/m
str = 'news/truststore.vendor.rst
news/12771.feature.rst
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end