using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((:?\D\d)+|(:?\d\D)+)$";
string input = @"H1e2l3l1
Hello
Hel1lo
a1b2c3d4
1b2c3d4e";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}