$re = '/^((:?\D\d)+|(:?\d\D)+)$/mi';
$str = 'H1e2l3l1
Hello
Hel1lo
a1b2c3d4
1b2c3d4e';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);