const regex = /^((:?\D\d)+|(:?\d\D)+)$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((:?\\D\\d)+|(:?\\d\\D)+)$', 'gmi')
const str = `H1e2l3l1
Hello
Hel1lo
a1b2c3d4
1b2c3d4e`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}