// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^((:?\D\d)+|(:?\d\D)+)$").unwrap();
let string = "H1e2l3l1
Hello
Hel1lo
a1b2c3d4
1b2c3d4e";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}