package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^if *\(([^:]+)\): ([^:]+) (?::else: ([^:]+) )?endif$`)
var str = `if(stat(life) >= 2): deal_damage(5) endif
if(stat(life) >= 2): abc(5) deal_damage(5) :else: gain_block(5) endif
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}