// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^if *\(([^:]+)\): ([^:]+) (?::else: ([^:]+) )?endif$").unwrap();
let string = "if(stat(life) >= 2): deal_damage(5) endif
if(stat(life) >= 2): abc(5) deal_damage(5) :else: gain_block(5) endif
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}