re = /^if *\(([^:]+)\): ([^:]+) (?::else: ([^:]+) )?endif$/m
str = 'if(stat(life) >= 2): deal_damage(5) endif
if(stat(life) >= 2): abc(5) deal_damage(5) :else: gain_block(5) endif
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end