const regex = /^if *\(([^:]+)\): ([^:]+) (?::else: ([^:]+) )?endif$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^if *\\(([^:]+)\\): ([^:]+) (?::else: ([^:]+) )?endif$', 'gm')
const str = `if(stat(life) >= 2): deal_damage(5) endif
if(stat(life) >= 2): abc(5) deal_damage(5) :else: gain_block(5) endif
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}