import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^if *\\(([^:]+)\\): ([^:]+) (?::else: ([^:]+) )?endif$";
final String string = "if(stat(life) >= 2): deal_damage(5) endif\n"
+ "if(stat(life) >= 2): abc(5) deal_damage(5) :else: gain_block(5) endif\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}