#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,9}\n"
Local $sString = "9372127603" & @CRLF & _
"9372130412" & @CRLF & _
"9372140" & @CRLF & _
"9372175041" & @CRLF & _
"937218" & @CRLF & _
"9372190908" & @CRLF & _
"9372191764"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")