import re
regex = re.compile(r"^\d{1,9}\n", flags=re.MULTILINE)
test_str = ("9372127603\n"
"9372130412\n"
"9372140\n"
"9372175041\n"
"937218\n"
"9372190908\n"
"9372191764")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")