package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,9}\n`)
var str = `9372127603
9372130412
9372140
9372175041
937218
9372190908
9372191764`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}