$re = '/^\d{1,9}\n/m';
$str = '9372127603
9372130412
9372140
9372175041
937218
9372190908
9372191764';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);