const regex = /^\d{1,9}\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{1,9}\\n', 'gm')
const str = `9372127603
9372130412
9372140
9372175041
937218
9372190908
9372191764`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}