re = /^\d{1,9}\n/m
str = '9372127603
9372130412
9372140
9372175041
937218
9372190908
9372191764'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end