using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[Uu]rl(?::|\b)\s?\b(.+?)(?:\s|$)";
string input = @"url: https://www.anysite/anything
url: https://www.anysite/anything another word
url: https://www.anysite/anything";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}