import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[Uu]rl(?::|\\b)\\s?\\b(.+?)(?:\\s|$)";
final String string = "url: https://www.anysite/anything\n"
+ "url: https://www.anysite/anything another word\n"
+ "url: https://www.anysite/anything";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}