// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[Uu]rl(?::|\b)\s?\b(.+?)(?:\s|$)").unwrap();
let string = "url: https://www.anysite/anything
url: https://www.anysite/anything another word
url: https://www.anysite/anything";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}