#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)-r(?:eason)?\s*"(.+?)(?:"\s*-|[^"]*$)"
Local $sString = "1 anything -reason "some reason" -anyArg "anything"" & @CRLF & _
"2 anything -reason "Hello World, you're the "best"" -anyArg "anything"" & @CRLF & _
"3 anything -r "anything "here" is wrong" anything"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")