$re = '/-r(?:eason)?\s*"(.+?)(?:"\s*-|[^"]*$)/m';
$str = '1 anything -reason "some reason" -anyArg "anything"
2 anything -reason "Hello World, you\'re the "best"" -anyArg "anything"
3 anything -r "anything "here" is wrong" anything';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);