const regex = /-r(?:eason)?\s*"(.+?)(?:"\s*-|[^"]*$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-r(?:eason)?\\s*"(.+?)(?:"\\s*-|[^"]*$)', 'gm')
const str = `1 anything -reason "some reason" -anyArg "anything"
2 anything -reason "Hello World, you're the "best"" -anyArg "anything"
3 anything -r "anything "here" is wrong" anything`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}