import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-r(?:eason)?\\s*\"(.+?)(?:\"\\s*-|[^\"]*$)";
final String string = "1 anything -reason \"some reason\" -anyArg \"anything\"\n"
+ "2 anything -reason \"Hello World, you're the \"best\"\" -anyArg \"anything\"\n"
+ "3 anything -r \"anything \"here\" is wrong\" anything";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}