#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:\d{11})?[^\S\n]*$).*(?:\n(?!\d{11}[^\S\n]*$).*)*\n\d{11}[^\S\n]*$"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et doloreere34545 magna aliqua. " & @CRLF & _
"" & @CRLF & _
"1\. Ut enim ad minim 5453 veniam" & @CRLF & _
"" & @CRLF & _
"2\. quis nostrud exercitation ullamco " & @CRLF & _
"14567883390" & @CRLF & _
"laboris nisi ut aliquip ex ea commodo consequat." & @CRLF & _
"12\. Duis aute irure dolor in reprehenderit in voluptate " & @CRLF & _
"velit esse cillum dolore" & @CRLF & _
"" & @CRLF & _
"23432434234 " & @CRLF & _
"eu fugiat nulla pariatur. Excepteur sint " & @CRLF & _
"occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"23432434234 " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"23432434234 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")