using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:\d{11})?[^\S\n]*$).*(?:\n(?!\d{11}[^\S\n]*$).*)*\n\d{11}[^\S\n]*$";
string input = @"Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et doloreere34545 magna aliqua.
1\. Ut enim ad minim 5453 veniam
2\. quis nostrud exercitation ullamco
14567883390
laboris nisi ut aliquip ex ea commodo consequat.
12\. Duis aute irure dolor in reprehenderit in voluptate
velit esse cillum dolore
23432434234
eu fugiat nulla pariatur. Excepteur sint
occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
23432434234
23432434234 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}