const regex = new RegExp('^(?!(?:\\d{11})?[^\\S\\n]*$).*(?:\\n(?!\\d{11}[^\\S\\n]*$).*)*\\n\\d{11}[^\\S\\n]*$', 'gm')
const str = `Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et doloreere34545 magna aliqua.
1\\. Ut enim ad minim 5453 veniam
2\\. quis nostrud exercitation ullamco
14567883390
laboris nisi ut aliquip ex ea commodo consequat.
12\\. Duis aute irure dolor in reprehenderit in voluptate
velit esse cillum dolore
23432434234
eu fugiat nulla pariatur. Excepteur sint
occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.
23432434234
23432434234 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}