import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:\\d{11})?[^\\S\\n]*$).*(?:\\n(?!\\d{11}[^\\S\\n]*$).*)*\\n\\d{11}[^\\S\\n]*$";
final String string = "Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et doloreere34545 magna aliqua. \n\n"
+ "1\\. Ut enim ad minim 5453 veniam\n\n"
+ "2\\. quis nostrud exercitation ullamco \n"
+ "14567883390\n"
+ "laboris nisi ut aliquip ex ea commodo consequat.\n"
+ "12\\. Duis aute irure dolor in reprehenderit in voluptate \n"
+ "velit esse cillum dolore\n\n"
+ "23432434234 \n"
+ "eu fugiat nulla pariatur. Excepteur sint \n"
+ "occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.\n\n\n\n"
+ "23432434234 \n\n\n"
+ " \n\n\n\n"
+ "23432434234 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}