#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(\d{4}[A-Z]{2}) ([\w\.\'\/\- ]+) (\w?[0-9]+[a-zA-Z0-9\- ]*)"
Local $sString = "# Simple " & @CRLF & _
"" & @CRLF & _
"5913ST PRINSENSTRAAT 6" & @CRLF & _
"3421ED OUDE SINGEL 11-21" & @CRLF & _
"6546EX HORSTACKER 16-44 A" & @CRLF & _
"5473CA PLEIN 1969 13A" & @CRLF & _
"6533VD ST. JACOBSLAAN 339" & @CRLF & _
"7622CN 'T DIJKHUIS 36" & @CRLF & _
"5022EH PATER V/D ELSENPLEIN 86" & @CRLF & _
"6533VD P/A ST. JACOBSLAAN 339" & @CRLF & _
"3262JP WEST-VOORSTRAAT 20" & @CRLF & _
"6212BP GLACISWEG 30 K-L" & @CRLF & _
"6216BX BECANUSSTRAAT 15A04" & @CRLF & _
"9663PR ALBATROSSTRAAT B75" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")