// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(\d{4}[A-Z]{2}) ([\w\.\'\/\- ]+) (\w?[0-9]+[a-zA-Z0-9\- ]*)").unwrap();
let string = "# Simple
5913ST PRINSENSTRAAT 6
3421ED OUDE SINGEL 11-21
6546EX HORSTACKER 16-44 A
5473CA PLEIN 1969 13A
6533VD ST. JACOBSLAAN 339
7622CN 'T DIJKHUIS 36
5022EH PATER V/D ELSENPLEIN 86
6533VD P/A ST. JACOBSLAAN 339
3262JP WEST-VOORSTRAAT 20
6212BP GLACISWEG 30 K-L
6216BX BECANUSSTRAAT 15A04
9663PR ALBATROSSTRAAT B75
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}