import re
regex = re.compile(r"^(\d{4}[A-Z]{2}) ([\w\.\'\/\- ]+) (\w?[0-9]+[a-zA-Z0-9\- ]*)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("# Simple \n\n"
"5913ST PRINSENSTRAAT 6\n"
"3421ED OUDE SINGEL 11-21\n"
"6546EX HORSTACKER 16-44 A\n"
"5473CA PLEIN 1969 13A\n"
"6533VD ST. JACOBSLAAN 339\n"
"7622CN 'T DIJKHUIS 36\n"
"5022EH PATER V/D ELSENPLEIN 86\n"
"6533VD P/A ST. JACOBSLAAN 339\n"
"3262JP WEST-VOORSTRAAT 20\n"
"6212BP GLACISWEG 30 K-L\n"
"6216BX BECANUSSTRAAT 15A04\n"
"9663PR ALBATROSSTRAAT B75\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")