import Foundation
let pattern = #"^(\d{4}[A-Z]{2}) ([\w\.\'\/\- ]+) (\w?[0-9]+[a-zA-Z0-9\- ]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
# Simple 
5913ST PRINSENSTRAAT 6
3421ED OUDE SINGEL 11-21
6546EX HORSTACKER 16-44 A
5473CA PLEIN 1969 13A
6533VD ST. JACOBSLAAN 339
7622CN 'T DIJKHUIS 36
5022EH PATER V/D ELSENPLEIN 86
6533VD P/A ST. JACOBSLAAN 339
3262JP WEST-VOORSTRAAT 20
6212BP GLACISWEG 30 K-L
6216BX BECANUSSTRAAT 15A04
9663PR ALBATROSSTRAAT B75
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)