# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{(.*?)}/$1/g;t' <<< "{0}{5}
{1}{dfdf}
{}
{}{}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}
"