import Foundation
let pattern = #"{(.*?)}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{0}{5}
{1}{dfdf}
{}
{}{}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)