use strict;
my $str = '{0}{5}
{1}{dfdf}
{}
{}{}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}
';
my $regex = qr/{(.*?)}/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";