re = /{(.*?)}/
str = '{0}{5}
{1}{dfdf}
{}
{}{}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result