package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{(.*?)}`)
var str = `{0}{5}
{1}{dfdf}
{}
{}{}
{2}{пара, пара п.а пара&па®}
{3}{dfdf!}
`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}