import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=signature date\\.\\r?\\n)\\w+(?=\\sSignatory attests)";
final String string = "to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.\n"
+ "Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the\n"
+ "Form 4506-C. See instructions.\n\n"
+ "to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.\n"
+ "X Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the\n"
+ "Form 4506-C. See instructions.\n\n"
+ "to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.\n"
+ "asdas Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the\n"
+ "Form 4506-C. See instructions.\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}