import Foundation
let pattern = #"(?<=signature date\.\r?\n)\w+(?=\sSignatory attests)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.
Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the
Form 4506-C. See instructions.
to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.
X Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the
Form 4506-C. See instructions.
to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.
asdas Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the
Form 4506-C. See instructions.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)