re = /(?<=signature date\.\r?\n)\w+(?=\sSignatory attests)/m
str = 'to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.
Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the
Form 4506-C. See instructions.
to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.
X Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the
Form 4506-C. See instructions.
to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.
asdas Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the
Form 4506-C. See instructions.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end