const regex = /(?<=signature date\.\r?\n)\w+(?=\sSignatory attests)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=signature date\\.\\r?\\n)\\w+(?=\\sSignatory attests)', 'gm')
const str = `to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.
Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the
Form 4506-C. See instructions.
to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.
X Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the
Form 4506-C. See instructions.
to execute Form 4506-C on behalf of the taxpayer. Note: This form must be received by IRS within 120 days of the signature date.
asdas Signatory attests that he/she has read the attestation clause and unon so reading declares that he/she has the authority to sign the
Form 4506-C. See instructions.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}