#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([0-9]{3,})"
Local $sString = "17091342 BaoDing QingYuan District Xtrcb Rural Bank Corporation Limit40156 0862315401 19D" & @CRLF & _
"17091327 Ren Xian Xtrcb County Bank Corporation Limited 50156 0862315402 19D"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")