use strict;
my $str = '17091342 BaoDing QingYuan District Xtrcb Rural Bank Corporation Limit40156 0862315401 19D
17091327 Ren Xian Xtrcb County Bank Corporation Limited 50156 0862315402 19D';
my $regex = qr/([0-9]{3,})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}