package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]{3,})`)
var str = `17091342 BaoDing QingYuan District Xtrcb Rural Bank Corporation Limit40156 0862315401 19D
17091327 Ren Xian Xtrcb County Bank Corporation Limited 50156 0862315402 19D`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}