const regex = /([0-9]{3,})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([0-9]{3,})', 'gm')
const str = `17091342 BaoDing QingYuan District Xtrcb Rural Bank Corporation Limit40156 0862315401 19D
17091327 Ren Xian Xtrcb County Bank Corporation Limited 50156 0862315402 19D`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}