using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([0-9]{3,})";
string input = @"17091342 BaoDing QingYuan District Xtrcb Rural Bank Corporation Limit40156 0862315401 19D
17091327 Ren Xian Xtrcb County Bank Corporation Limited 50156 0862315402 19D";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}