import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{3,})";
final String string = "17091342 BaoDing QingYuan District Xtrcb Rural Bank Corporation Limit40156 0862315401 19D\n"
+ "17091327 Ren Xian Xtrcb County Bank Corporation Limited 50156 0862315402 19D";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}