using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^https?:\/\/sodaphonic.com\/audio\/([a-zAA-Z0-9]+)(.*)$";
string input = @"https://sodaphonic.com/audio/344uhz2j8NUJjyUkckQq
https://sodaphonic.com/boombox
https://twitter.com/sodaphonic/status/1529218638712020995
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}