$re = '/^https?:\/\/sodaphonic.com\/audio\/([a-zAA-Z0-9]+)(.*)$/m';
$str = 'https://sodaphonic.com/audio/344uhz2j8NUJjyUkckQq
https://sodaphonic.com/boombox
https://twitter.com/sodaphonic/status/1529218638712020995
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);