// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/sodaphonic.com\/audio\/([a-zAA-Z0-9]+)(.*)$").unwrap();
let string = "https://sodaphonic.com/audio/344uhz2j8NUJjyUkckQq
https://sodaphonic.com/boombox
https://twitter.com/sodaphonic/status/1529218638712020995
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}