use strict;
my $str = 'https://sodaphonic.com/audio/344uhz2j8NUJjyUkckQq
https://sodaphonic.com/boombox
https://twitter.com/sodaphonic/status/1529218638712020995
';
my $regex = qr/^https?:\/\/sodaphonic.com\/audio\/([a-zAA-Z0-9]+)(.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}